The HEPEK Project

hepek

For many years i have been thinking about “Hepek”. Fabulous joke from my favorite TV show.

Seems like we have something now.

First stage would be to build simple “device” and try to promote the further idea i have about “Hepek” and what it should be. I already made some contacts in China build it and ship it here, but minimum order is 10k. I’m not sure if i’ll get it through them. Also i’m not sure about the quality and the fact that somebody would copy my products. However, first stage is to build 100 peaces, announce it publicly, share it with people and get the response. Than, other decisions will come. First PCBs will be ordered soon, i’m just not sure about buzzer/speaker and battery. Arduino, even the tiny one, uses a lot of power.

Anyways, Moblie/Web app is in in development. I hope i’ll ave some prototype soon. Who knows…

Some content about it:


Mikrotik and Cloudflare

I always hated no-ip and other dynamic dns services. Thankfully cloudflare made our life easier, especially with introducing and API.

It so unusual since i it has bee awhile since i had to play with networks.
I believe this could be useful to some. Plain and simple, i believe the most simple Mikrotik script which pushes your public IP to a Cloudflare via Cloudflare API.

First thing that you need to do is to set “Mikrotik ip cloud”. with /ip cloud set ddns-enabled=yes. You can check if the address is propagated with /ip cloud print
p.s. Only for the latest Mikrotik with Cloud thing available!!!

##############Script Settings##################
:local cfEmail “[your cf login email]”
:local cfToken “[cf token which you can find in your account settings]”
:local cfZone “data.ba”
:local cfRocordType “A”
:local cfDomainTTL “1”
# this param sets cf pref, if you need cache put 1
:local serviceMode “0”
# ID param can be fetched through “https://www.cloudflare.com/api_json.html?a=rec_load_all&tkn=[token]&email=[email]&z=[main-domain]” and look for “rec_id”
:local subdomainId “[if of a “sub” domain you want to set, find it by: ]”
:local subdomainName “”

############## Build CF API Url ################
:local CFurl “https://www.cloudflare.com/api_json.html\3F”
:set CFurl ($CFurl . “a=rec_edit&tkn=$cfToken&id=$subdomainId”);
:set CFurl ($CFurl . “&email=$cfEmail&z=$cfZoneone&type=$cfRocordType”);
:set CFurl ($CFurl . “&name=$subdomainName&service_mode=$serviceMode&ttl=$cfDomainTTL”);

###############################################
:globa publicip [:put [/ip cloud print as-value]]
:local NewIP [:put ($publicip->”public-address”)]

/tool fetch mode=https url=”$CFurl&content=$newIP” keep-result=no
:log info “CF Update: $subdomainName – $newIP”


Sarajevo songs

All songs about Sarajevo and all that mention Sarajevo in some context.

rajvosa


Facebook’s bug in “Promote post” engine and fake clicks???

1. Story:

I noticed something strange in facebook’s “Promote post” system. I started promotion for article in one group and stopped it before it was approved. However, surprise was that they charger me 5$ for that 🙂 I claimed it via paypal and received money back. In Facebook they didn’t even try to respond to my claim. So i had to wait for 20 days to get 5$ back.

I’m wondering, if anyone else noticed the same???

facebook-paypal

2. Story:

I recently published web site (http://www.adriablues.com) for a friend and he asked me to promote it on facebook. As usual, i placed analytics code in page on the very same  day. We didn’t try to promote web site anywhere else. Strange thing happened. Facebook add was linked directly to web page URL however, i noticed in Google Analytics three time less page views than clicks for which facebook charged us. And when i viewed referrer clicks, it was even less from facebook.

Please, review print screens together with dates and number of clicks reported by Facebook and by Google analytics.

facebook-analytics

google-analytics

 

I would not comment any more for now. It’s just what happened!?!?!?

UPDATE  18. APRIL.2013 (12:32)

I just logged in my FB account, and i got this FASCISM message.  FACEBOOK DON’T LIKE IF YOU COMPLAIN WHEN THEY LIE ABOUT YOUR CLICKS. BIG BROTHER 😀 HA HA HA

facebook-dispute

 

We are writing to let you know that there were charges made on your account that have
been disputed by the owner of the payment instrument.

 

In the future we encourage you to contact us first if you have any questions or issues
with charges made on Facebook by visiting the Facebook Help Center at
https://www.facebook.com/help/?page=871. A Facebook representative will be happy to
work with you to resolve the matter and issue refunds when appropriate.

 

You may continue to use Facebook Ads, however, if we receive any additional disputes
for charges on your account, it may be disabled permanently. If you have any questions
regarding this email, please view our Help Center Dispute Section at
https://www.facebook.com/help/?page=216072835093424.

 

Please do not reply to this message, as it is unmonitored.

 

We appreciate your cooperation.

 

Thanks,
Risk Management


Raspberry Pi | MSP430 | Arduino Uno | PICkit 2 Debug Express

Boards named in title of this article are not very much comparable.
Actually, Raspberry Pi is the one that breaks harmony 🙂

 

The one thing which is in common for sure is the fact that these boards are popular among EE students and hobbyists. Or at least, they tend to be. Of course, there are many other boards, but i have only these.

 

However, what i can compare is maybe quality of how these boards are made and shipped, what i like and don’t like about that.

 

1. Raspberry Pi A or B [the interloper] 🙂  (35$ + shipping which can be up to 50$…very suspicious)

  • Hard to order lately
  • Development environment quite handy
  • IT DOESN’T COME WITH nice rubber pads 🙁 You really need to spend 6-20$ more for proper casing and cables
  • As it’s real computer with many different ports, i don’t know what you can’t do with it 😀

 

2. MSP430 (4.3$ with shipping, they tend to get become popular platform so you even get VERY FAST shipping)

  • The cheapest – almost free !!!
  • Development VERY tricky, not Linux friendly and that is the main reason you don’t want to spend even 4.5$
  • Seems to be the top quality board in terms of material of all four (How i know it? :D)
  • Not many example projects for easy get into development

 

3. Arduino Uno (arround 35$ + shipping)

  • The most popular – which makes learning very easy
  • Development very friendly for all platforms
  • Many different shields available
  • You would not get far if you only stick to it (although i have heard of companies that use it for serious industrial projects ccc)

 

4. Debug Express board PIC 16F887 (around 60$ but comes with programmer and debugger!!!)

  • Comes with PICkit 2 or 3 Programmer and debugger which can be used to program most of  PICs you could imagine as student or hobbyist and with PIC16F887
  • Since Microchip published MPLABX and appropriate cross platform compiles, development became multi-platform friendly which is quite surprise for LInux users
  • IMHO it’s decent small platform but it would be my favorite if they added small breadboard instead. Would not change cost much and would be much more approachable to go through exercises.
  • Fastest opening doors towards serious microcontroller development (IMHO)

controllers

 

Boards with couple of Arduino shields.

 


Thinkpad T430 + Debian Squeeze + Backports

This post is about what can you expect right now, installing Debian on Thinkpad T430.

 

Just out of box + Debian squeeze install?

Almost nothing works ok. 🙂 Default kernel is something arround 2.6.3 or so and most of your hardware will simply not work. However, i noticed that the webcam was working fine and drivers for wireless cards are in non-free squeeze repos 🙂

 

After adding Backports to repository & upgrading to 3.2 Kernel?

nVidia graphics, Bluetooth and Audio card starts working just buy upgrade.

 

Missing:
Sierra Gobi 3000 (mobile broadband + GPS + Sending SMS-es) [Partially solved, mobile broadband is functioning]
Fingerprint reader [Found solution, seems like there is a way for new device 147e:2020 Upek to be recognized by libbsapi]
Microphone Mute led indicator [There is solution, need to modify and rebuild thinkpad_acpi.ko]
Fn + Display brightness doesn’t work. [I especially don’t like it when it comes on from “sleep” mode. I have no idea how to fix it currently…]

[Solutions and tips to be added …]

 

The configuration:

Processor: Intel Core i5-3320M Processor (3M Cache, up to 3.30 GHz)
Display Type: 14.0″ HD+ (1600 x 900) LED Backlit AntiGlare Display, Mobile Broadband Ready
System Graphics: NVIDIA NVS 5400M Graphics with Optimus Technology, 1GB DDR3 Memory
Total Memory: 16 GB DDR3 – 1600MHz ( 2 x 8Gb)
Pointing Device: UltraNav with Fingerprint Reader
Camera: 720p HD Camera with Microphone
Hard Drive: 120Gb SSD (Kingston HyperX)
Ultrabay: DVD Recordable
System Expansion Slots:  Express Card Slot & 4-in-1 Card Reader & Smart Card Reader
Battery: 6 Cell Li-Ion TWL 70+
Bluetooth: Bluetooth 4.0 with Antenna
Integrated: WiFi Wireless LAN Adapters Intel Centrino Ultimate-N 6300 AGN
Integrated: Mobile Broadband Integrated Mobile Broadband (Sierra Wireless MC8355 – Gobi 3000 (TM))

MR. BASIC Model TR-3 (Scientific & Educational Material) for 25$

I was so excited when i find this little toy on ebay. I really believed that it’s impossible for such “simple” TOY to be so bad.

As most people who bought something from China via ebay know, it’s common to wait about 30 days for item to arrive. So that was first horrible experience.

Just when i opened the box, i was very excited. Everything seemed to be well packed, in proper box and even with simple manual. But as i started assembling it, i realized that this 25$ ware not well spend. Here is short list of what i find out.

 

  1. There are two DC motors, each one for 4.5V and b default, there is 3xAA battery case.
  2. Screws for battery case stick out so batteries would not connect properly. So i bought new 4xAA battery box, with ticker plastic, made different wider holes.
  3. Shafts connecting wheels and motors are the worst quality mechanical parts i have ever seen on models like this one.
  4. HORRIBLE thing is that there is no simple way to remove top board in order to reach batteries. So every time you want to charge batteries, you should unscrew three hardly reachable nuts and remove the board.
  5. Horrible manual with wrong instructions 🙂
  6. TERRIBLE plastic pinions, probably the weakest point and the most important one in this platform.

 

I think that any other comment is unnecessary.

Just few images down there:

MR. BASIC Model TR-3 img1

MR. BASIC Model TR-3 img2

MR. BASIC Model TR-3 img3

MR. BASIC Model TR-3 img4


What happened with printers. (Today’s printing volume per toner is 1/5 of what it used to be tan years ago).

The point is obvious, but why do’t we talk more about this?

 

Few years ago, my last LaserJet 6P broke after probably millions of copies.  Unfortunately i can’t find any repaired or refurnished now, so i had to switch to some newer models that even have “Professional” in their name. So i bought HP Laserjet Pro P1102w.

 

What is the problem?

 

Well, refilled toner for my old LaserJet 5P and 6P printers costs about 20 euros where for new LaserJets it’s about 23 euro. That would all be fine if there was no terrible efficiency difference.

 

LaserJet 6P was able to print about 7000 to 7500 copies per toner, where any other newer LaserJet is not able to reach even 1500 properly.   🙁


The future of “computer * ” dr. Yale N. Patt

I don’t know exactly if i have right to publish this video. It’s and old but very cute one :).
I believe you will find it as worth spending 1 hour.

 

The future of “computer * ” dr. Yale N. Patt

IEEE Computer Society

60 Anniversary Reception

14. June 2006


20 years of IBM / Lenovo ThinkPads

For a number of years i use ThinkPad. Since i’m big fan of IBM/Lenovo ThinkPad and since it has been almost 20 years as IBM / Lenovo started producing ThinkPads, i decided to post something about that. 😀

Some reasons why ThinkPad is so great:

I like about it:

  1. It’s made of finest plastic and has very robust casing.
  2. In most cases you will never have problems with linux drivers and there is even www.thinkwiki.org for linux users. (community supported with plenty of tips, tricks and tutorials).
  3. There is plenty of additional accessories like docking station, etc…
  4. You can customize fully customize it if you purchase it online. Choose monitor, fingerprint reader, bigger battery, wi-fi chip, processor etc.. (i just wish that i could choose keyboard with big  Enter button, it’s a fail).
  5. IBM/Lenovo leads with innovations in Laptops through the long history of almost 20 years.
  6. It’s so good that it is even being used at ISS 😀 (Image from ISS)
  7. At most of developer conferences to which i attended i saw people carrying ThinkPads, it’s the maybe the best proof that ThinkPad IS GREAT LAPTOP

Sad about it:
Very expensive..

This would be “best birthday present” IMHO 😀

 


eskort escort bayan escort istanbul escort istanbul escort istanbul escort istanbul